Ram Rebel Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I've owned my 2020 Rebel (all stock and 41k miles) for about 2 weeks. A couple nights ago on the way home, the 12" screen was blank. Nothing we did would revive it. When I got home I tried one of the reboot sequences (that i think now is not correct), holding power and tune for 10 seconds and it did nothing. I disconnected the battery overnight and it came on when I started the next morning. That day it went blank again. I performed a new reset sequence which included put in ACC, holding power/tune for 30 sec, turning off, opening door, etc. Again the screen came on when cranked. I don't know if it will hold but I'm assuming it won't. I haven't checked the software version yet (and don't know how to yet), but was hoping someone here already had a good fix. From what I can tell researching this morning, there aren't any good solutions. I looked for more threads on this and didn't find any. If there are some, I would appreciate someone pointing them out.
 

· Super Moderator
Joined
·
227 Posts
I have no idea what the issue is with the blank screen, only that I have read about it happening before and I dont recall any real fix for it

But to look up you software version, you’ll have to have a working screen
  • go to settings on the head unit
  • then there should be a choice for Software or something similar…. I want to say it’s the last thing listed in settings
 

· Registered
Joined
·
5 Posts
I have a 2022 rebel with the 12" screen and it has done something similar one time.. Screen when blank when I started and never came on during the 2 mile drive (no issue with instrument cluster). Left it overnight and when I checked it in the morning everything worked as normal.

Can you share a link to your reset steps just in case I run into this again?
 

· Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Not sure this works for everyone, but worked on my 2020 with 12" screen.

1) Put in ACC or run mode without cranking and with all doors closed
2) Hold down Tuner and Volume knobs for at least 30 seconds and let go
3) Turn vehicle off
4) Open drivers door for 30 sec or until lights turn off
5) Get in and close the door
6) Start the truck

When I restarted everything came on and I didn't loose any of the settings. The screen hasn't blinked since. I am in discussion with RamCares to see if my software is up to date.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I contacted Ramcares and they got back with me very quickly. He said my App number (not software version, apparently it depends on year of truck) was out of date and the update is supposed to address that. However, since it has behaved correctly since the reset he said not to bother updating unless it happens again. So i guess ill just wait and hope.
 
1 - 7 of 7 Posts
Top