Ram Rebel Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Now have 1100 miles. From day one. it seems to have a very small inclination to drift to the left, but not always. Have paid attention to it occurring on level and different road slants and it doesn't seem to matter. The interesting thing, as I noted, is that it doesn't seem to be there all the time. I'm starting to think it may be associated with either acceleration or coasting and am going to pay more attention to that. It just doesn't seem to be an alignment issue as the drift would pretty much be there all the time, but it looks like I just may have to take it back to be checked. Any other experiences or thoughts?
 

·
Registered
Joined
·
1,408 Posts
Sounds like a minor alignment problem, honestly. I assume you've checked your tires and their the same inflation, left to right. Those are the two most common causes, you haven't put enough wear on the tires for them to cause it from uneven wear.
 

·
Registered
Joined
·
933 Posts
Tie rod end? If you have a worn or loose one that might cause the intermittent drift.
 

·
Registered
Joined
·
1,408 Posts
At 1100 miles, a worn one would be really odd, but a loose one is a good possibility. If you take it in for an alignment check, that should be obvious to the dealership. I'd take it in, just because you don't want the uneven tire wear if the alignment is out.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Now have 1100 miles. From day one. it seems to have a very small inclination to drift to the left, but not always. Have paid attention to it occurring on level and different road slants and it doesn't seem to matter. The interesting thing, as I noted, is that it doesn't seem to be there all the time. I'm starting to think it may be associated with either acceleration or coasting and am going to pay more attention to that. It just doesn't seem to be an alignment issue as the drift would pretty much be there all the time, but it looks like I just may have to take it back to be checked. Any other experiences or thoughts?
Sounds like a minor alignment problem, honestly. I assume you've checked your tires and their the same inflation, left to right. Those are the two most common causes, you haven't put enough wear on the tires for them to cause it from uneven wear.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Good point. The truck is so new, I haven't got to the point of checking the obvious. I did see on the display a few days ago that the tire pressures were in the 60 psi range? Thought that was high but was driving and forgot to look into it later. Going to go back and look at that. Thanks for the info.
 

·
Registered
Joined
·
933 Posts
Good luck
 

·
Registered
Joined
·
176 Posts
Good point. The truck is so new, I haven't got to the point of checking the obvious. I did see on the display a few days ago that the tire pressures were in the 60 psi range? Thought that was high but was driving and forgot to look into it later. Going to go back and look at that. Thanks for the info.
Don't forget to check if your front bumper is level, lately a lot have been coming thru crooked, on the passenger side.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top