Ram Rebel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
so this happened yesterday, straight to dealer and a new touchscreen on order. Not a good start to my new truck ownership with 260 miles total on the truck.


 

·
Registered
Joined
·
269 Posts
Quick question...is the red light on the center of the mirror illuminated?

I had an 8.4 issue when mine was brand new but it was a persistent error...nothing like what you're describing (and showing).

I'm sure they'll just replace the 8.4 head unit and it'll work out. Thats what warranties are for. Good luck and keep us updated!

They did fix my error issue...it was the sharkfin antenna that was bad. Yours looks more like an actual 8.4 head unit screen error of some type.
 

·
Registered
Joined
·
226 Posts
Try doing a hard reset, press and hold the volume button and the tune button at the same time until it resets.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Quick question...is the red light on the center of the mirror illuminated?

I had an 8.4 issue when mine was brand new but it was a persistent error...nothing like what you're describing (and showing).

I'm sure they'll just replace the 8.4 head unit and it'll work out. Thats what warranties are for. Good luck and keep us updated!

They did fix my error issue...it was the sharkfin antenna that was bad. Yours looks more like an actual 8.4 head unit screen error of some type.


No the light in the mirror? Not on.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Try doing a hard reset, press and hold the volume button and the tune button at the same time until it resets.


Sent from my iPhone using Tapatalk

Can press anything, the touchscreen is already recognizing a touch! Except of course no one is touching it. Basically it renders the screen totally unusable
 

·
Registered
Joined
·
269 Posts
It needs to be replaced...not sure a reset would even work.

The only thing I would try before taking it to the dealership is taking the battery connections off for 10 minutes and then putting them back on...see if it takes care of the issue (temporarily).

Just an idea. I'd make an appointment with the dealer...either way....that type of issue is unacceptable .

Its not the same issue as my 8.4 problem. Keep us updated.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
It needs to be replaced...not sure a reset would even work.

The only thing I would try before taking it to the dealership is taking the battery connections off for 10 minutes and then putting them back on...see if it takes care of the issue (temporarily).

Just an idea. I'd make an appointment with the dealer...either way....that type of issue is unacceptable .

Its not the same issue as my 8.4 problem. Keep us updated.

Dealer has a new touchscreen on order, said priority but haven't got a call from them yet. I did notice when it is happening right above the touchscreen unit it is very hot. When it is acting ok it is cool up there.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Grrrr dealer said priority but now part wont be in until next week, pretty crappy service. Not happy at all.
 

·
Registered
Joined
·
12 Posts
Quick question...is the red light on the center of the mirror illuminated?

I had an 8.4 issue when mine was brand new but it was a persistent error...nothing like what you're describing (and showing).

I'm sure they'll just replace the 8.4 head unit and it'll work out. Thats what warranties are for. Good luck and keep us updated!

They did fix my error issue...it was the sharkfin antenna that was bad. Yours looks more like an actual 8.4 head unit screen error of some type.
I also had an issue, but mine was the satellite antenna as well. Quick swap out by dealer, no issues since.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
New update, just left the dealership with them saying Chrysler had sent a reman/used unit to put into my 1 1/12 week old 400mile truck. I told them where they could put that, and it wasn't in my truck!
After more discussion I basically told them I want my money back or another truck. Hopefully Chrysler will just pull a new unit off the production line and it can be installed in my truck and all will be good.
I was told it wouldn’t be the first time Chrysler has had to buyback a vehicle within the first month and they had a process for it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
So update, truck still in the shop. Chrysler I guess went with a new manufacturer for 2018 for the stereo/gps/ touchscreen unit. So none are available. At least they gave me a 3500 to drive while they scratch there heads and say “I dunno”
 

·
Registered
Joined
·
2,606 Posts
Hope for the best...stuff happens and at least they will make it right ....or try to anyway...
 

·
Registered
Joined
·
11 Posts
Discussion Starter #15
Finally have the truck back,
All is working properly! I was told that they switched manufacturers for the 2018 model year. Had to pull a new unit off the factory production line so I was told.
 

·
Registered
Joined
·
269 Posts
Good to hear they got it worked out. Hopefully thats the last of your 8.4 screen issues. My 8.4 issue on my 2017 Rebel was the dreaded "Vehicle Phone Requires Service" error. They replaced the head unit and it didn't fix it. Turned out it was the shark fin antenna on the roof that had a kink in the line. It wasn't allowing the head unit to connect to the cell towers. Got my issue worked out...took 3 trips to the dealer total...but...its fixed.
 
1 - 16 of 16 Posts
Top