Ram Rebel Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Picked up the truck a month ago. Installed the 5100 and new ucas on a ‘17 without air suspension. I’m in the US. It doesn’t have the Bilstein front, had what I am assuming is stock with the 1”? They’re black, not yellow. Rear is stock Bilstein. I know you don’t need the adapter ring for the 5th gen, does it apply to this set up as well? Having a hard time figuring out what the old set up is to answer this.

Have it on the 0.7 setting and it’s currently 22.5 front and 23.25 rear, center of hub to fender or 37.25 front, 38.25 rear (ground to fender). Which technically gave me a 1.5” lift from before and then the rear dropped? Im not sure how that worked out. It’s maybe an inch higher on the passenger side. First had it on the 2.1 setting everyone uses and it jacked it up too much. The old set up was definitely ready for a refresh as it completely changed all my measurements from before as it originally had like 3” of rake (so in theory 2.1 made sense). I do have the adapter on, but only because I wasn’t sure with the non Bilstein front. I’m not really sure what’s going on.

Willing to redo it at the moment. Just double checking the work and whether or not to raise it to 1.4 with or without the adapter. The rake as is is fine I suppose, but now I have no clue what my actual lift is (was shooting for 3 based on old measurements). I’m probably just making up issues that aren’t there in my head haha.
 
1 - 1 of 1 Posts
Top