Ram Rebel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I put adjustable links on my truck. Backend raised 4" up, the front never moved and now it froze there. I have put the stock links back but still nothing has changed front hasn't moved and rear maxed out. Have held both buttons to reset with no difference. Disconnected battery for 30 minutes with no difference. Does anybody know of a way to reset?
 

·
Registered
Joined
·
109 Posts
Drive it. At 15 mph it automatically goes in to recalibrate mode. Don't touch the buttons while it's doing that or it will stick in that position. It won't tell you it's doing anything. Just drive it for a mile then go back and remeasure.
As a side note on the adjustable links, having fooled around with these a fair bit my experience is that they work great for adjusting the rear height with a lot of room to adjust them but the front doesn't like being raised more than about 3/4". Doing more than that seems to throw codes in the air ride. I am currently up a little over an inch in the rear and just 3/4 in the front. Enough to fit the tires with no discernible impact on ride quality. I would love a little more lift than this, but think going with a proper suspension lift is the better way to go for that since any higher in the rear definitely makes it a rougher ride.

Sent from my SM-G925W8 using Tapatalk
 

·
Registered
Joined
·
115 Posts
I agree with above. I just got adjustable links and I only put the front links on and raised the front about an inch (the rear also rose by default, about 1/2-3/4"). I wanted to level the truck (raise front and keep rear the same) but not sure it'll work that way.
 

·
Registered
Joined
·
109 Posts
Sorry I forgot a step in my post above, press and hold the up and down buttons at the same time for 5 seconds.....then drive it to at least 15 MPH.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
I went back to the dealership and they had me going in 30 minutes! One of the sensors had fell off of it's stop nothing broken. Anybody using the links my advice is the air ride is very sensitive on the links a little bit goes a long way!! Thank all of you for the help!!
 
1 - 6 of 6 Posts
Top