Ram Rebel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Last Friday I got home from work and detailed the inside of the truck. Then on Sunday I got up nice and early to pack my truck for a week long camping trip with the family. Truck loaded, family in and...... click! There's lights and all seems well just didn't start. So I push the button again and..... click! Sounds as if it doesn't want to turn over. Then the message appears... Immediate service/repair to Air Suspension required. Check engine light is on and flashing.

Fast forward to today, the truck is in the same state. Suspension is completely lowered on all four corners. check engine light is on and blinking. I can't start the truck to get it to a repair shop.

Any suggestions?

Should I just do away with the air suspension and convert to coil overs?

2016 Ram Rebel 4wd 5.7
just over 71,000 miles
All services have been done by Dodge & Jeep Dealerships at their suggested intervals.
 

·
Registered
Joined
·
271 Posts
Thats what I did its not worth the headache up here but what is weird is that your check engine light is on and blinking if you got a way to scan it id start there something might have put your truck in limp mode and thats why the air ride isn't working
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
So after checking fuses and going through stored messages. it appears the truck has issues....

Service Electronic Braking System
Service Anti-Lock Braking System
Immediate Service/Repair to Air Suspension Required

Only the cluster works. Brake pedal feels depressed. 8.4 Uconnect screen does not turn on. Air suspension lights are on but buttons do nothing. Truck is sitting all the way down on all four corners.

Ugh....
 

·
Registered
Joined
·
271 Posts
Your probably gonna have to get her brought in and looked at normally I'd say might be just a fuse but you checked those and if you got those 3 things goin on ya at the same time maybe a module went bad on ya or maybe you might have unplugged something under the seat while detailing but I can't really think of anything under there that would cause this thats about all I can think of sorry bud
 

·
Super Moderator
2020 Rebel Rambox
Joined
·
197 Posts
These kinds of issues are rough, stealership scan tool is your best bet.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
BATTERY!!!!! tested @ 18v which is out of range. Original battery finally died.... Replaced battery, everything went back to normal. So I traded in the Rebel and here is the replacement

31066


Just wanted to finish out the thread for future searches.
 

·
Registered
Joined
·
26 Posts
Honestly start with the battery. Legit this happened to me roughly a month ago, I left the accessories on for like 30 min by accident and when I tried to turn it on same issue. Just the only thing was about the truck being all the way lowered that didn't happen to me but I'm assuming since it had only been like an hour after. Try to jump start it because same issue I had and go from there. I have a 2015 ram rebel 4x4 too so
 

·
Registered
Joined
·
90 Posts
I have a 2019 Rebel. About two months ago I started having some issues. I only drive my truck on average two days a week unless I'm on a weekend trip or vacation etc. I'm retired and detail cars on the side. Anyway, On the two days a week I drive I lower the setting to entry/exit when I get home and park in the garage. About two months ago I started noticing the rear end jacked up and the front a lot lower. As I stood next to the truck I could hear clicking noises coming form he rear end. I'm no mechanic but after researching some I believed it was the compressors to the air suspension. Then my battery started to drain. I live in the desert and the heat kills batteries like crazy. About two years + if your garage your vehicle. Then my battery was completely dead. I took it in to the dealer. They told me a cell was dead in the battery so they replaced my battery, kept the truck over night to do some overnight testing and said all tests passed. I picked the truck up the next day. I had a mother vehicle in my garage for a complete detail so I parked my truck int he driveway. As it got dark I checked to make sure my truck was locked. Standing next to it I could hear the clicking noises again. This time I looked inside the truck when I heard the clicking noises in the rear. The dash lit up as if you were pushing the start button, then the radio screen popped on. After a short time the radio screen went out and then the USB port lights (front and rear) would come on. The dash screen would go dark but the USB lights stayed on. Then the rear would click again and the process would start all over. I was able to capture it on video. I contacted the dealer who said they would get back to me and ..... still waiting..... Good thing I have the lifetime max care warranty. I have a feeling I'm going to be needing it.
 
1 - 9 of 9 Posts
Top