Ram Rebel Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #2
Unable to activate 4 wheel drive? Has anyone come across this issue it seems all fuses are good?
 

·
Registered
Joined
·
2,622 Posts
So your saying that when you push the button for 4 wheel high, or low, the indicator light and dash light don't come on?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
So your saying that when you push the button for 4 wheel high, or low, the indicator light and dash light don't come on?
Yes that’s correct including the lower manual controls are not working either ie; suspension indicators heated seats and any other button on that strip of options.
 

·
Registered
Joined
·
248 Posts
I'm not sure if that's a question or not... but anyways I have a long history of fuses blowing and weird things happening (looking at you caravan!) Figured it might be worth a look anyway
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
Absolutely 1st thing I thought of was a blown fuse, that's what I'm hoping not sure what happened...
 

·
Registered
Joined
·
2,622 Posts
I believe that system 4x4, heated seats, heated steering wheel all have a individual relay. I hear it click on every time I hit the seat warmers and steering wheel
 

·
Registered
Joined
·
14 Posts
Discussion Starter #14
Good information to know because I’ve been using the heated seats and steering lately too! I can still use some of those features heated sets via the touch screen and it does work from there? Very weird problem, I do hear that relay click when engaging heated seat from touch screen.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
All my manual buttons ie; suspension are non- functional and no indicator lights? Hope it’s something simple?
 

·
Registered
Joined
·
68 Posts
This happened to me in my 2014 Outdoorsman (6'4'' bed). With no air ride. However, I turned my truck on and off a 2-3x and everything started working properly after the 3rd start....

the issue never reoccured- and everything worked as it should on the 4x4 selector buttons, as well as what everything else is on the lower control panel.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
Thank you all for your input - the dealership tells me that it’s a faulty “Intelligent Battery Sensor”...
 
1 - 20 of 22 Posts
Top