Ram Rebel Forum banner

1 - 20 of 73 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Mine include loose hood still cant get it figured even with new hood, dash flicker, crooked bumper, and had my transmission module go at 700km
 

·
Registered
Joined
·
95 Posts
I have a whistle when driving above 55mph... Turns out its the windshield wiper blades o_O no resolution determined yet but if you take off the blades no whistle, this is with both stock and aftermarket.
 

·
Registered
Joined
·
40 Posts
I have a whistle when driving above 55mph... Turns out its the windshield wiper blades o_O no resolution determined yet but if you take off the blades no whistle, this is with both stock and aftermarket.
Hmmmm.... mine doesn't whistle....
 

·
Registered
Joined
·
42 Posts
Mine include loose hood still cant get it figured even with new hood, dash flicker, crooked bumper, and had my transmission module go at 700km
crooked bumper here too. i nosed up to a tree, put it in 4 low drove forward and pushed it back, now it is straight again.
 

·
Registered
Joined
·
153 Posts
Mine include loose hood still cant get it figured even with new hood, dash flicker, crooked bumper, and had my transmission module go at 700km
For your dash flickering check your fuse box, mine started to do that so I checked the fuse box. I had to push all the fuses in all the way. I just noticed that my bumper is a little crooked too the other day. Would the dealership be able to fix this, or is a tree my only option? I'm taking my truck in tomorrow for the shaft recall.
 

·
Registered
Joined
·
14 Posts
The cylinder deactivation doesn't come on consistently. When it comes on I get really good gas mileage. When it doesn't my mileage sucks. Driving at the same speeds on the same roads at different times the MDS should work the same but it doesn't. My 3 previous Rams didn't have this over sensitive cylinder deactivation.

At 60 mph cruising I can get 22 mpg or I can get 15 mpg. All depends on what the MDS feels like doing.
I hope that there is a fix for this.
 

·
Registered
Joined
·
1,285 Posts
For your dash flickering check your fuse box, mine started to do that so I checked the fuse box. I had to push all the fuses in all the way. I just noticed that my bumper is a little crooked too the other day. Would the dealership be able to fix this, or is a tree my only option? I'm taking my truck in tomorrow for the shaft recall.
Odd to me why they aren't all pushed in from the factory. I popped two fuses and it was because of loose connections. Since I pushed then all in no more issues.
 

·
Registered
Joined
·
1,285 Posts
I have a whistle when driving above 55mph... Turns out its the windshield wiper blades o_O no resolution determined yet but if you take off the blades no whistle, this is with both stock and aftermarket.
I didn't have one....then did...now don't...mine was my front grill light bar though...
 

·
Registered
Joined
·
1,285 Posts
The cylinder deactivation doesn't come on consistently. When it comes on I get really good gas mileage. When it doesn't my mileage sucks. Driving at the same speeds on the same roads at different times the MDS should work the same but it doesn't. My 3 previous Rams didn't have this over sensitive cylinder deactivation.

At 60 mph cruising I can get 22 mpg or I can get 15 mpg. All depends on what the MDS feels like doing.
I hope that there is a fix for this.
Thought I was the only one....mine is very erratic too
 

·
Registered
Joined
·
105 Posts
The fuse issue seems to be pretty consistent in all the forums with everyone's Rebels (2015 and 16's). My USB IN would go in and out, dashboard flickers, etc. It was the fuses. On every new "intro" post I see, I feel obligated to say "welcome my friend, now stop what you're doing, go outside, and push all of your fuses in."
 

·
Registered
Joined
·
1,285 Posts
The fuse issue seems to be pretty consistent in all the forums with everyone's Rebels (2015 and 16's). My USB IN would go in and out, dashboard flickers, etc. It was the fuses. On every new "intro" post I see, I feel obligated to say "welcome my friend, now stop what you're doing, go outside, and push all of your fuses in."
Most idiotic manufacturing mishap I have ever seen
 

·
Registered
Joined
·
153 Posts
I talked to a service member at the dealership and he said that he is going to try to fix the alignment to the front and back bumper (i noticed the back was crooked too.) He said that if they can't fix it they are going to try and order a new bumper. The dealer I went to has three new rebels on the lot and they all have the crooked bumpers too, all exactly the same way.
 

·
Registered
Joined
·
63 Posts
Hate to say it, even though I own a Rebel, but FCA is not known for building high quality vehicles. I worked for them and wish I had bought a more reliable brand. Between my Rebel and Charger I usually have one vehicle lined up to go I for something or another.
 

·
Registered
Joined
·
39 Posts
My first 2 months were rough. First issue was to replace entire fuel system. Could not put gas in it due to a faulty breather valve. It would literally take 30 minutes to fill up at .50 cents at a time. This repair took 2 weeks. Next was flooded with water from the sunroof with the first torrential downpour. Fix was replace entire sunroof and all wet electronics. Took another 2 weeks. Chrysler reimbursed me $1,000 and gave me a 7 year 70,000 mile bumper to bumper warranty for the trouble. All in all it's still the saddest and best truck I have owned, and I've had em all. I wouldn't trade it for anything, but there are definitely issues with the sunroof. If yours is leaking, run to the first dealer ASAP.
 

·
Registered
Joined
·
50 Posts
I had a sunroof in my 13 outdoorsman and now I miss the extra light; never had an issue.

But like you I had a fuel issue....it was a fuel sensor (tank had to be dropped).
 

·
Registered
Joined
·
50 Posts
My first 2 months were rough. First issue was to replace entire fuel system. Could not put gas in it due to a faulty breather valve. It would literally take 30 minutes to fill up at .50 cents at a time. This repair took 2 weeks. Next was flooded with water from the sunroof with the first torrential downpour. Fix was replace entire sunroof and all wet electronics. Took another 2 weeks. Chrysler reimbursed me $1,000 and gave me a 7 year 70,000 mile bumper to bumper warranty for the trouble. All in all it's still the saddest and best truck I have owned, and I've had em all. I wouldn't trade it for anything, but there are definitely issues with the sunroof. If yours is leaking, run to the first dealer ASAP.

I paid over two grand for a bumper to bumper 6 year warranty. At least they gave you something.
 

·
Registered
Joined
·
6 Posts
I'm having some of the same issues with my rebel. My dash gauge lights were flickering but it stopped when I turned the lights up and continued again when I turned it down again then just stopped altogether. The rebel is definatly harder on fuel I found. A couple days ago went to start my truck and my brake pedal was stiff and could barely push it down but still was able to start it and then it was fine. All in all the issues are minor.
 
1 - 20 of 73 Posts
Top