Ram Rebel Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hello people!

I hope everyone is enjoying their Rebel! I just updated my uconnect system to v16.33.29, up from v15.xx.xx. did any of you guys update their system as well? Any issues with IOS 10? or Iphone 7 for that matter?
As for Update, its fairly easy and straight forward! Visit driveuconnect.com, well in my case driveuconnct.ca for people living in Canada!
You enter your vin number and follow the instructions, and then when the file is downloaded as a ZIP file, extract the files to a usb and plug it in as per instructions! Be Sure to update it in an open area because you leave the car running and my update took 30 minutes!
Just wanted to share this info!
And as always... Rebel is a way of life:)
 

·
Registered
Joined
·
1,408 Posts
Last update they provided in April via that method bricked a couple of guys' UConnects. They talked about that in the forums here. Don't recall any followups on how they got fixed. If they got fixed.
 

·
Registered
Joined
·
69 Posts
Just updated mine. Did it twice by accident. Some of my icons are coming up with ! in them. Not sure what's going on there.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
Just updated mine. Did it twice by accident. Some of my icons are coming up with ! in them. Not sure what's going on there.
Sorry to hear that! You can visit the dealership and they'll probably figure it out. In one of the informational videos posted on youtube, I do recall someone had to update it twice, but thats because it didn't work the first time, and the guy didn't mention anything about this ! mark coming up.

All the best bruv!
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
Last update they provided in April via that method bricked a couple of guys' UConnects. They talked about that in the forums here. Don't recall any followups on how they got fixed. If they got fixed.
I checked a couple of threads and everyone seems to be fine with it. The update itself was 1281 MB, so I assumed it was Apple Carplay or Android Auto... But the Nav Maps look a bit different and the system itself seems to run smoother.I wish we had Uconnect Access in Canada...

Cheers Bud!
 

·
Registered
Joined
·
1,408 Posts
Good that it's working better this time.

In this case Apple's IOS 10 must have something modified in its drivers that makes them no longer compatible with devices like UConnect. There are complaints in scores of car forums and in the Apple forums. Looks like they've borked pretty much every car system they worked with, somehow.

Microsoft's Windows 10 broke the computer I was using to feed streaming video (Netflix, etc.) to my home theater system last year, through a straight HDMI feed. The pc had Win7 on it, and it worked fine. Then the wife upgraded it to Win10, which was supposed to be "better." But what it did was add DRM (digital rights management - i.e. copy protection s/w) to the HDMI drivers, which pretty much borked them. Now my very expensive theater/stereo system no longer works with that computer. Microsoft claims that the theater (a Denon) isn't compatible. So I installed Linux on the pc and now everything is fine again.
 

·
Registered
Joined
·
69 Posts
Sorry to hear that! You can visit the dealership and they'll probably figure it out. In one of the informational videos posted on youtube, I do recall someone had to update it twice, but thats because it didn't work the first time, and the guy didn't mention anything about this ! mark coming up.

All the best bruv!
I don't think I actually needed to update it twice, but I wasn't paying attention and updated it from the same version to the same version haha. Anyways the icons reappeared a few mins later so I'm GTG!
 

·
Registered
Joined
·
38 Posts
Hello people!

I hope everyone is enjoying their Rebel! I just updated my uconnect system to v16.33.29, up from v15.xx.xx. did any of you guys update their system as well? Any issues with IOS 10? or Iphone 7 for that matter?
As for Update, its fairly easy and straight forward! Visit driveuconnect.com, well in my case driveuconnct.ca for people living in Canada!



You enter your vin number and follow the instructions, and then when the file is downloaded as a ZIP file, extract the files to a usb and plug it in as per instructions! Be Sure to update it in an open area because you leave the car running and my update took 30 minutes!
Just wanted to share this info!
And as always... Rebel is a way of life:)

hello, can you tell me what files to put on the usb? the .iso file only?
thanks
did it before on my charger but i am having difficulty this time.
 

·
Registered
Joined
·
66 Posts
Question..i purchased my rebel in the states but now reside in Canada. Do you think I should download update from US site or the CA one?

Thank you.
 

·
Registered
Joined
·
330 Posts
Question..i purchased my rebel in the states but now reside in Canada. Do you think I should download update from US site or the CA one?

Thank you.
Always use the country of origin. Your truck was built for the US so stick with it. If the site is built properly, when you put in your VIN it should know the country of origin and only allow the proper one. In today's age of companies wanting the impossible for free I wouldn't asume the site was built properly though.
 

·
Registered
Joined
·
76 Posts
I did this update for both my rebel and the wife's cherokee. About an hour total time for both. Once I had the update downloaded and extracted, it was pretty painless.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
76 Posts
So.....if you open this video on the computer and look at the description......this is a hack that they did over in Europe. I do not see this as being a capability from a software update from UConnect.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #18 ·
hello, can you tell me what files to put on the usb? the .iso file only?
thanks
did it before on my charger but i am having difficulty this time.
Hello Rebeldan, sorry for the late reply!! I can't recall exactly what I saved on the usb stick, but the video about the Uconnect Update on youtube mentions how you're supposed to save the files. I followed the instructions but I did a mistake at first by copying a part of the files and the system couldn't read it, so I had to go back upstairs (live in a condo:mad:), re-do the download and then plugged in the usb stick
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top