Ram Rebel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
276 Posts
Discussion Starter #1
Having to go into the dealer tomorrow to have the windshield washer looked at, the fluid coming out of the jets hardly hits the lower edge of the screen.
Anyone else had this problem?
 

·
Registered
Joined
·
1,285 Posts
No sir. Let us know what they find.
 
  • Like
Reactions: Rebel.Law

·
Registered
Joined
·
276 Posts
Discussion Starter #3
Faulty pump and they had a replacement in stock
 

·
Registered
Joined
·
1,285 Posts

·
Registered
Joined
·
952 Posts
I had the washer fluid heater installed. Every once in a while the pressure in the tank will squirt a few drops out onto the hood without activating it. Needless to say I have lots of pressure and in the winter the heated fluid is a life saver.
 

·
Banned
Joined
·
248 Posts
I had the washer fluid heater installed. Every once in a while the pressure in the tank will squirt a few drops out onto the hood without activating it. Needless to say I have lots of pressure and in the winter the heated fluid is a life saver.
Chris,
Is that a dealer installed option ?
 

·
Registered
Joined
·
952 Posts
Not an option but a dealer item that is installed by them.
 

·
Registered
Joined
·
952 Posts

·
Registered
Joined
·
952 Posts
  • Like
Reactions: Rebel.Law

·
Registered
Joined
·
952 Posts

·
Registered
Joined
·
952 Posts

·
Registered
Joined
·
82 Posts
Having to go into the dealer tomorrow to have the windshield washer looked at, the fluid coming out of the jets hardly hits the lower edge of the screen.
Anyone else had this problem?
Hey @Gismo i had the same issue with mine when it came off the lot, they had to replace the pump. Same as you, they had it in stock so I'm all good now.
 

·
Registered
Joined
·
2 Posts
Having to go into the dealer tomorrow to have the windshield washer looked at, the fluid coming out of the jets hardly hits the lower edge of the screen.
Anyone else had this problem?
Gidday Mate,
I had the same issue early in my truck life. My dealer suggested it had to do with the material that lined the washer fuild container. Once they cleaned the container everything has been fine (60,000km) on.
Gabe
 
1 - 15 of 15 Posts
Top